DeVry SEC 450 All ILabs Latest

$110

Quantity:

Description

DeVry SEC 450 All ILabs Latest

 

DeVry SEC 450 Week 2 ILab Latest

iLab 2 of 7: Security Demands

Note!

Submit your assignment to the Dropbox, located at the top of this page.

(See the Syllabus section “Due Dates for Assignments & Exams” for due dates.)

ILAB OVERVIEW

Scenario and Summary

In this lab, the students will examine the following objectives.

  • Create ACL to meet the requirements of the security demands.
  • Modify existing ACL to meet additional security requirements.

Deliverables

Students will complete all tasks specified in the iLab Instructions document. As the iLab tasks are completed, students will enter CLI commands, and answer questions in the iLab Report document. This iLab Report document will be submitted to the iLab Dropbox for Week 2.

Supporting Documentation

  • .equella.ecollege.com/items/09f64419-688f-40ae-9f8d-aebde0633824/0/SEC450_W1_3_ACL_Tutorial.docx”>SEC450 ACL Tutorial
  • Textbook (Chapter 3)
  • Webliography links on Access Control List

Required Software

  • Access the software at .next.ecollege.com/default/launch.ed?ssoType=DVUHubSSO2&node=skillSoftSSO&orgCode=org_35″>Skillsoft

ILAB STEPS

STEP 1: Access Skillsoft iLab

.equella.ecollege.com/file/7b8aae86-1708-4e11-8548-fa7813ab5cba/25/SEC450_W2_iLab.html#top”>Back to Top

Access Skillsoft Labs at the provided iLab link, and select Catalog. Click to Launch the course and then select Lab2. Then, download the PDF instructions. Ensure that you open and read the iLab instructions before you begin the lab.

PLEASE NOTE: Lab instr

STEP 2: Perform iLab 2

.equella.ecollege.com/file/7b8aae86-1708-4e11-8548-fa7813ab5cba/25/SEC450_W2_iLab.html#top”>Back to Top

Download and open .equella.ecollege.com/file/7b8aae86-1708-4e11-8548-fa7813ab5cba/25/SEC450_W2_Security_Demands_Lab2_Report.docx”>SEC450_W2_Security_Demands_Lab2_Report.docx.Follow the instructions to perform all procedures in this week lab. Instructions in red indicate tasks that you need to answer and include in the lab report.

STEP 3: Complete Your Lab Report

.equella.ecollege.com/file/7b8aae86-1708-4e11-8548-fa7813ab5cba/25/SEC450_W2_iLab.html#top”>Back to Top

When you are satisfied with your documentation, submit your completed report to the Dropbox.

Submit your lab to the Dropbox, located at the top of this page. For instructions on how to use the Dropbox, read these .next.ecollege.com/default/launch.ed?ssoType=DVUHubSSO2&node=node/184″>step-by-step instructionsor watch this .next.ecollege.com/default/launch.ed?ssoType=DVUHubSSO2&node=node/232″>Dropbox Tutorial.

See the Syllabus section “Due Dates for Assignments & Exams” for due date information.

<pclass=”msotitle” style=”box-sizing: border-box; user-select: initial !important;”>Studen</pclass=”msotitle”>

<pclass=”msotitle” style=”box-sizing: border-box; user-select: initial !important;”>

Security Demands Lab

SEC450 Week 2 iLab2 Report

Copy below each of the tasks that appears inred in the pdf lab Instructions from Skillsoft. Then, write the answer following each of the tasks. Submit this document to the iLab Dropbox in Week 2.

DeVry SEC 450 Week 3 ILab Latest

Lab 3 of 7: Database Security Demands

Note!

Submit your assignment to the Dropbox, located at the top of this page.

(See the Syllabus section “Due Dates for Assignments & Exams” for due dates.)

ILAB OVERVIEW

SEC450 ACL Tutorial

This document highlights the most important concepts on Access Control List (ACL) that you need to learn in order to configure ACL in CLI. This tutorial does not intend by any mean to cover all ACL applications, but only those scenarios used in the SEC450 iLabs.

Introduction to Access Control List

  • A host-based firewall essentially works closing and/or opening ports in a computer.The engine behind firewalls is built with Access Control Lists (ACL).
  • Network-based firewalls are implemented in device-specific appliances and routers.Basically, firewalls in routers filter packets through interfaces to permit or deny them.
  • Ports are layer-4 address specified in TCP/IP protocol suit that identify networking processes running in clients and servers.
  • ACLs are configured using shell-specific commands.In Cisco IOS, CLI commands access-list and access-group are used to create and apply ACL on an interface.
  • ACL can be named by number ID or a name.Naming ACL is useful to identify ACL’s purpose.
  • ACL are classified in Standard ACL and Extended ACL.
  • Standard ACL’s number IDs are assigned from 1 to 99.Extended ACL’s number IDs are from 100 to 199.
  • Standard ACL only uses source IP address in an IP packet to filter through an interface.Hence, standard ACL denies or permits all packets (IP) with the same source IP regardless upper protocols, destination IP address, etc.Example 1: Router(config)#access-list 8 deny host 172.12.3.5
  • Extended ACL does filtering packets based on protocol, source IP address, source port number, destination IP address, and destination port number.Example 2: Router(config)#access-list 102 deny tcp host 10.0.3.2 host 172.129.4.1.Deny tcp packets with source IP address 10.0.3.2 and destination IP address 172.129.4.1.
  • Since, Standard ACLs only have source IP address; the rule is to apply them in an interface as closer as possible to the destination IP address.
  • For the contrary, the rule for Extended ACLs is to apply them in an interface as closer as possible to the source IP address.
  • Use Extended ACL in all iLabs as they are more granular on packet filtering.

Create Extended ACL in global configuration

  • You can use access-list command options lt, gt, eq, neq, and range (less than, greater than, equal, not equal, range of ports) to do operation with port numbers.

Example 3: access-list 102 deny tcp any host 11.23.45.7 gt 20 denies all packets with any source IP address to destination IP address 11.23.45.7 and destination tcp port greater than 20.

Example 4: access-list 107 permit udp any any permits all packets with udp protocol with any source IP address to any destination IP address.

  • Extended ACL can do packet filtering based on source port number and destination port number.
  • Extended ACL Syntax can be as follows.

access-list <#,name> <protocol> host <source_ip> <port_qualifier> <source_port_number> host <dest_ip> <port_qualifier> <dest_port_number>

where:

<#,name> is a number between 100 to 199 or a one-word name

<protocol> is any protocol in the TCP/IP suite

<source_ip> and <dest_ip> are the source and destination IP addresses

<port_qualifier> is optional, and can be eq, gt, lt, neq, and range

<source_port_number> and <dest_port_number> follow <port_qualifier> to specify the port number(s). <port_qualifier> and <port_number> can be replaced by the application protocol. Example, http instead of eq 80.

  • Creation of ACL follows the three Ps rule.One ACL per protocol, per interface, per traffic direction.Per protocol means ones protocol such as IP, TCP, IPX, UDP, or ICMP can be specified. Per interface means the ACL is applied to an interface to make it active. Per direction means the ACL needs to specify which direction at the interface, packet in or out, filtering applies.
  • Steps for configuring a new ACL are: First, create the ACL in CLI global configuration using access-list command(s).Then, apply the ACL using access-group command in CLI interface configuration.The ACL is activated unless it is applied to an interface.
  • An ACL consists of one or more access-list commands.Routers process the ACL commands in order; top first to bottom last likewise a scripting or computer program.That is why the order of access-list commands makes a difference.
  • The effectiveness of an access-list command depends upon previous access-list commands.Therefore, always write the commands following the order; more-specific-traffic commands first and, then more-generic-traffic commands last.Example 5: It makes sense to write an ACL as

Router(config)#access-list 101 deny tcp host 10.0.3.2 any

Router(config)#access-list 101 permit tcp any any

But never follows the order below, because the second command is more specific, and therefore, “deny” is worthless because the first command already lets packets passing through.

Router(config)#access-list 101 permit tcp any any

Router(config)#access-list 101 deny tcp host 10.0.3.2 any

  • All ACL have a hidden access-list command at the end that denies all packets (i.e., deny ip any any).Hence, packets that are not specifically permitted in a command will always be denied by the ACL.

Example 6: Use command Router(config)#access-list 105 permit ip any any at the end of ACL if it requires to permit all other traffic after denying packets with Router(config)#access-list 105 deny icmp any host 192.168.10.244

  • Wildcard option is used in access-list commands filtering packets from a subnet of source and/or destination IP addresses instead of single hosts.IP addresses in each of those subnets must be continuous.Filtering on port numbers is also applicable, but it have been omitted for the sake of simplicity. Here is the syntax.

access-list <#,name> <protocol> <source_ip> <source_wildcard> < <dest_ip> <dest_wildcard>

where:

<#,name> is a number between 100 to 199 or a one-word name

<protocol> is any protocol in the TCP/IP suite

<source_ip> and <dest_ip> are the source and destination IP addresses

<source_wildcard> and <dest_wildcard> specify the subnet ranges of source and destination IP addresses

  • Wildcard in ACL has the same meaning as in routing protocols such as EIGRP and OSPF.Wildcard bit 0 means the bit in the IP address must be the same as the corresponding bit in the subnet IP addresses.Wildcard bit 1 means the bit in the IP address can be any value (0 or 1).

Example 7: access-list 105 deny udp 172.16.7.3 0.0.0.3 any means to deny all packets with udp protocol with source IP addresses from 172.16.7.0 to 172.16.7.3 to any destination IP address. Note that .3 is in binary .00000011 and .000000xx for wildcard, where x means any (0 or 1).

Example 8: access-list 109 permit tcp host 192.168.6.3 eq 80 10.0.0.0 0.0.0.255 means to permit all tcp packets from source IP address 192.168.6.3 and source port tcp 80 (e.g., http server) to destination IP addresses in range 10.0.0.0 to 10.0.0.255.The fact that 10.0.0.0 would not qualify for host IP in classful networks is irrelevant to the ACL.

  • Using wildcard with all 0s is the same as using the option host in access-list commands.Example 9: access-list 110 permit ip host 10.23.4.3 host 10.30.2.1 and access-list 110 permit ip 10.23.4.3 0.0.0.0 10.30.2.1 0.0.0.0 are equivalent commands.Both permit filtering packets with source IP address 10.23.4.3 and destination IP address 10.30.2.1.
  • Only use wildcard in access-list commands when the ACL requires filtering packets on subnet of IP addresses; either at source, destination, or both.

Applying ACL to an Interface to activation

  • Example 10: Assume you need to create an ACL in router that permits filtering any traffic excepting udp packets with source IP address 10.23.4.3 and destination IP address 10.30.2.1 as shown in the network diagram below.
  • First, you need to create an extended ACL in CLI global configuration.

Router#config t

Router(config)#access-list 103 deny udp host 10.23.4.3 host 10.30.2.1

Router(config)#access-list 103 permit ip any any

  • Second, you need to apply ACL 103 in an interface closer to the source (e.g., extended ACL rule of thumb).The closer interface is S0/1 in Router for traffic coming from IP 10.23.4.3.Thus, you go to interface configuration in CLI to activate the ACL.

Router(config)#interface s0/1

Router(config-if)#ip access-group 103 in

  • If you need to make any correction after creating an ACL, then erase first the ACL from global and interface configurations.To erase ACL 103 from the previous example execute the following commands.

Router(config)#interface s0/1

Router(config-if)#no ip access-group 103

Router(config)#no ip access-list 103

Now, you can start over creating ACL 103. If you do not erase the ACL, then new access-list commands will be compounding in the configuration file producing unexpected behavior. Use command show run to verify the ACL is erased and created again correctly.

Verify ACL Configuration

  • Example 11: Let’s say you have been asked to create an ACL in a router R to deny TCP traffic coming through interface Serial 0/2 from source IP address 10.16.2.1 to destination IP address172.16.5.3 with destination port number greater than 200.Also, the ACL should permit filtering any other traffic.
  • There are two configuration tasks you need to do in CLI.First, create the ACL.Second, apply the ACL to interface Serial 0/2.
  • So, in CLI,

R> enable

R# config t

R(config)# access-list 101 deny tcp host 10.16.2.1 host 172.16.5.3 gt 200

R(config)# access-list 101 permit ip any any this command is needed to permit any other traffic after denying the selecting packets from the first command.

R(config)# interface serial0/2

R(config-if)# ip access-group 101 in this command is to apply the ACL to serial0/2 for traffic coming in.

R(config-if)# exit

R# show run this is to verify the ACL configuration is correct in running-config.file

R#show running-config

version 12.3

!

hostname R

!

interface FastEthernet0/0

ip address 192.168.200.1 255.255.255.0

!

interface FastEthernet0/1

ip address 192.168.20.1 255.255.255.0

shutdown

!

interface Serial0/0

ip address 200.100.20.2 255.255.255.0

!

interface Serial0/1

ip address 192.168.30.2 255.255.255.0

shutdown

!

interface Serial0/2

ip address 192.168.40.1 255.255.255.0

ip access-group 101 in

!

router rip

network 192.168.200.0

network 200.100.20.0

!

ip default-network 200.100.20.0

ip route 0.0.0.0 0.0.0.0 serial0/0

!

!

access-list 101 permit tcp host 10.16.2.1 host 172.16.5.3 gt 200

access-list 101 permit ip any any

!

!

line con 0

line aux 0

line vty 0 4

password cisco

line vty 5 15

password cisco

!

end

  • If the ACL is not correct, then delete it with the command below and start over again

R# config t

R(config)# no access-list 101

R(config)# interface serial0/2

R(config-if)#no ip access-group 101

DeVry SEC 450 Week 4 ILab Latest

<pclass=”msonormal” style=”box-sizing: border-box; user-select: initial !important;”>AAA Server Authentication Lab

SEC 450 Week 4 iLab 4 Report

Copy below each of the tasks that appears inred in the pdf lab instructions from Skillsoft. Then, write the answer following each of the tasks. Submit this documment to the iLab Dropbox in Week 4.

 

DeVry SEC 450 Week 5 ILab Latest

iLab 5 of 7: VPN – Virtual Private Networks

Note!

</pclass=”msonormal”></pclass=”msotitle”>

Submit your assignment to the Dropbox, located at the top of this page.

(See the Syllabus section “Due Dates for Assignments & Exams” for due dates.)

<pclass=”msotitle” style=”box-sizing: border-box; user-select: initial !important;”>Student Name: Date:</pclass=”msotitle”>

IPSec Site-to-Site VPN Lab

SEC450 Week 5 iLab5 Report

Copy below each of the tasks that appears inred in the pdf lab Instructions from Skillsoft. Then, write the answer following each of the tasks. Submit this documment to the iLab Dropbox in Week 5.

 

DeVry SEC 450 Week 6 ILab Latest

iLab 6 of 7: IDS/IPS – Intrusion Detection/Prevention Systems

Note!

Submit your assignment to the Dropbox, located at the top of this page.

(See the Syllabus section “Due Dates for Assignments & Exams” for due dates.)

Student Name: Date:

Intrusion Detention System (IDS/IPS) Lab

SEC450 Week 6 iLab6 Report

Copy below each of the tasks that appears inred in the pdf Lab Instructions from Skillsoft. Then, write the answer following each of the tasks. Submit this documment to the iLab DropBox in Week 6.

 

DeVry SEC 450 Week 7 ILab Latest

iLab 7 of 7: Network Vulnerability Case Study

Note!

Submit your assignment to the Dropbox, located at the top of this page.

(See the Syllabus section “Due Dates for Assignments & Exams” for due dates.)

<pclass=”msotitle” style=”box-sizing: border-box; user-select: initial !important;”></pclass=”msotitle”>Student Name _________________________________ Date _____________

SEC450 Network Vulnerability Case Study—iLab7

Objectives

In this lab, students will examine the following objectives.

  • Differentiate the use of IDS and IPS to detect network attacks.
  • Design a network with IDS/IPS.
  • Justify the use of IDS/IPS for a given network solution.

Scenario

A small company is using the topology shown below to secure its intranet while providing a less-secured environment to its eCommerce DMZ server. The company is concerned that firewalls are not enough to detect and prevent network attacks. Hence, deployment of sensors to intrusion detection systems (IDS) and/or intrusion prevention systems (IPS) are needed in the network.Your job is to provide recommendations, including a network design with IDS/IPS, that meet the company’s requirements.

Initial Topology

.png”>

Company’s Requirements

  1. 1.Detect any malicious traffic entering the e-commerce server without performance penalty to traffic getting in the server from revenue-generating customers.
  2. 2.Stop any malicious traffic entering the human resources LAN (HR LAN).
  3. 3.Detect any malicious traffic entering the computer terminal in the marketing LAN (MKT LAN).
  4. 4.Stop any traffic entering the File Server in MKT LAN.
  5. 5.Deploy a centralized database and analysis console in the intranet to managing and monitoring both IDS and IPS sensors.

Note: RED text indicates the required questions to answer

Task 1—Layout the New Network Design

Click on the Initial Network Topology link on the iLab page in Week 7, and save in your computer the MS Powerpoint fileInitial_Network_Topology_iLab7.ppt. This file contains a diagram for the initial network topology and pictures of all components needed to create the new network design.

Review the documentation provided in the references at the end of these instructions to get more familiar with the implementation of IDS and IPS in network design. You need to find a network solution that meets the company’s requirements.

#1. Paste below your new network design diagram.

Task 2—IDS/IPS Recommendations

#2. Write an engineering specification document of at least 250 words (e.g., 1 page of full text, double space, and size 12) describing why your network’s design meets each of the company’s requirements. Justify how each recommendation addresses the company’s needs.


Task 3—Conclusions


#3. Describe in two paragraphs your learning experience in this lab.

References:

1.SANS Institute. “Network IDS & IPS Deployment Strategies“—Webliography

2.Paquet, C. (2012). Implementing Cisco IOS network security (IINS) foundation learning guide (2nd ed.). Indianapolis, IN: Cisco Press.

3.NIST. “Guide to Intrusion Detection and Prevention Systems (IDPS)”—Webliography

DeVry Courses helps in providing the best essay writing service. If you need 100% original papers for DeVry SEC 450 All ILabs Latest, then contact us through call or live chat.

DeVry SEC 450 All ILabs Latest

Best DeVry SEC 450 All ILabs Latest

DeVry SEC 450 All ILabs Latest